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Document Purpose
The purpose of this document to provide an overview of the Smile EZ Publish Eclipse Plugin and its
installation process.
This is Draft material developed to help the EZ community, and because this extension looks like it can
bring some important capabilities and opportunities to EZ and the EZ community.
Many thanks to the team at Smile (www.smile.fr).
This document probably contains more detail than most experienced EZ developers/users will need, but
it is presented in this way to help people who are new to EZ to understand and make use of this
extension. This is important because helping more people to get more value out of EZ Publish more
quickly is a way to grow and strengthen the EZ community … which helps us all.
I hope this helps you.
Regards
Paul Wilson
March 2007
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Important Disclaimer
This documentation is provided on a no liability basis. It is based on personal notes developed from using EZ
Publish. Please contact EZ Systems (www.ez.no) or an EZ accredited partner / professional developer if you
need to have reliable, thorough, and up-to-date information or services.

About the Author
Paul Wilson
B.Com, G.Dip Sc (IT), B.Comp (Hons)

Some of Paul’s work experience has included:
• Designing strategies, projects and education programs to accelerate the adoption of e-commerce by
businesses and industries in regional Australia – as part of the Australian Government’s first major
program of this type (1998-2002);

•

Co-authoring university (MBA) and national industry training courses on e-commerce and Internet-

related business strategies;
•

Co-authoring research and strategy reports on national ICT training needs across regions and industries
for Australian State and National government organisations.

Paul has been using EZ Publish to further his (now discontinued) PhD studies and professional work, with a
view to creating shared knowledge systems for businesses, industries and community organisations.
Paul lives in Tasmania, Australia. He enjoys getting away from a computer screen for mountain-biking and (too
infrequently now) sailing.

© P T Wilson, 2007

2

1 Eclipse – Overview Information
Some introductory information on Eclipse follows.
“Eclipse is an open source community whose projects are focused on building an open
development platform comprised of extensible frameworks, tools and runtimes for building,
deploying and managing software across the lifecycle. A large and vibrant ecosystem of major
technology vendors, innovative start-ups, universities, research institutions and individuals extend,
complement and support the Eclipse platform.”
(source: www.eclipse.org, accessed 13th March 2007)
What is Eclipse?
Eclipse is an open source community whose projects are focused on building an extensible
development platform, runtimes and application frameworks for building, deploying and managing
software across the entire software lifecycle. Many people know us, and hopefully love us, as a
Java IDE but Eclipse is much more than a Java IDE.
The Eclipse open source community has over 60 open source projects. These projects can be
conceptually organized into seven different "pillars" or categories:
1.
2.
3.
4.
5.
6.
7.

Enterprise Development
Embedded and Device Development
Rich Client Platform
Rich Internet Applications
Application Frameworks
Application Lifecycle Management (ALM)
Service Oriented Architecture (SOA)

The Eclipse community is also supported by a large and vibrant ecosystem of major IT solution
providers, innovative start-ups, universities and research institutions and individuals that extend,
support and complement the Eclipse Platform.
(source: www.eclipse.org/home/newcomers.php, accessed 13th March 2007)

1.1 References - Eclipse
•

Eclipse Site
www.eclipse.org

•

Eclipse Download Page
http://www.eclipse.org/downloads/ (version 3.2.2 is around 125Mb)

•

Eclipse - EZpedia Entry
http://ezpedia.org/wiki/en/ez/eclipse
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2 Smile EZ Publish Eclipse Plugin
Information from EZ Publish Contributions area (see link below):
Author

Version

Compatible with

Nicolas Richeton

0.0.14

eZ Publish 3.x, Eclipse 3.2, Java 1.5

eZ Publish plugin for the Eclipse IDE. Syntax highlighting, code generation, content classes
browser. This plugin is developed by Smile (http://www.smile.fr) and released under GPL.
Provides :
* TPL Syntax highlighting
* Code generation for operator extensions
* Browser for all content classes defined in eZ Publish.

Note:
“Ideas and bug reports can be submitted on the sf.net site.”
Sourceforge Project Homepage
http://sourceforge.net/project/showfiles.php?group_id=190833

2.1 References - Smile EZ Publish Eclipse Plugin
•

Extension Developer – Smile
www.smile.fr

•

Contribution information on ez.no
http://ez.no/community/contribs/3rd_party/smile_ez_publish_eclipse_plugin

•

Sourceforge Project Homepage
http://sourceforge.net/project/showfiles.php?group_id=190833
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2.2 Smile EZ Publish Eclipse Plugin - What it Does
The Smile Plugin does three main things:
•

Template Syntax Highlighting

•

Code Generation for Operator Extensions

•

Browser for your site’s EZ Publish Content Classes

These are explained further below.

2.2.1 Template Syntax Highlighting
EZ Publish template files loaded into Eclipse show syntax highlighting. For example:

2.2.2 Content Class Browser
The plugin includes an EZ Publish extension called smileclasses. This generates an XML page that
includes EZ Publish class information. For example:
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This XML page is used within Eclipse to provide a browser for your site’s EZ Publish content classes.
For example:

2.2.3 Code generation for operator extensions

WARNING
Be careful with this part, which can generate a new operator extension in a few steps.
Some files will be automatically created and others OVERWRITTEN (see section 2.8,
below). However, we included checks to prevent bad use and accidental loss of data.
Nicolas Richeton (source:
http://ez.no/community/contribs/documentation/installation_documentation_smile_ez_p
ublish_eclipse_plugin )
© P T Wilson, 2007
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This set of features is not explained or explored in detail in this document.
However, with Eclipse loaded, from the main menu, select File > New > Other
The following page will then be displayed, showing wizards for creating EZ Publish code.

2.3 EZ Publish - Installing the SmileClasses Extension
The Smile plugin includes an EZ Publish plugins folder.

Upload this smileclasses folder to your EZ Publish installation’s extension folder.
On your site’s Admin/Setup/Extensions page, enable this extension
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This is not necessary for setting up the extension, but you can check that this extension is working by
going to the page enabled by the extension. For example:
www.yoursite.com/index.php/eng/smileclasses/export
An XML representation of you site’s content object will then be generated. For example:

2.4 Download Eclipse
Eclipse is required for this extension to function.
If you do not already have Eclipse (version 3.2), it is available for download from the eclipse.org site’s
download page (http://www.eclipse.org/downloads/). Eclipse version 3.2.2 is around a 125Mb
download.
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Once downloaded, unzip Eclipse – perhaps to a folder in your programs directory.

For more information and instructions, please check the Eclipse site.
Once Eclipse has been extracted, it can be run using “eclipse.exe” in the root directory of the extracted
eclipse files.

(For usability purposes, if you are using Microsoft Windows, you may want to create a short-cut to
eclipse.exe on your desktop)
The eclipse loading page will then be displayed and then environment loaded.
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2.5 Adding the Smile Plugin to Eclipse (Automatic Update Method)
There are two methods for adding the Smile Plugin to Eclipse – an automatic method described here,
and a manual one, described in section 2.6, below. Only one of these is required. This first Automatic
Update method is more straightforward.
In Eclipse, from the main menu, select Help > Software Updates > Find and Install
This will bring up the following window.

Select “search for new features to install” and then click the “next” button. The following page will be
loaded.
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The following window will be displayed … add the information shown below and click “ok”. (The
actual name used does not matter, but is required by Eclipse).

The Smile EZ Publish Eclipse Plugin will now be listed in the update sites to visit, as shown below.

Click on Finish. Eclipse will then immediately search for updates, and will then open the following
window.
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Click on the check-box adjacent to the Smile EZ Publish Eclipse Plugin and then click the “Next”
button. The following page will be displayed.
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If you have read the licence agreement and choose to accept it, click the option for this, and then click
the “Next” button. The following page will be displayed.

If this information is correct, then click “Finish” to complete the installation. (At this stage Eclipse may
show further information about the plugin before proceeding with the installation). Eclipse will then
install the plugin and seek to restart.

2.6 Adding the Smile Plugin to Eclipse (Manual Method)
[This step is not required if you have already successfully completed
the steps explained in section 2.5, above]
The Smile plugin includes an EZ Publish plugins folder.

The files in this folder are:
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Copy these to the “plugins” folder in Eclipse

You should close and restart Eclipse at this point.
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2.7 Loading EZ Publish Content Classes into Eclipse
In Eclipse, from the top menu, select:
Window > Show View > Other
This will bring up the following window, which includes Smile eZ Publish and a sub-item “Classes
View”.

Select “Classes” View and then click “Ok”. This will open a “Classes View” window adjacent to the
main working area of Eclipse. Enter your site’s URL and path to the smileclasses/export page in the top
line of this view window.
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Click on the “Go” button and the following will be displayed. It has been loaded from your site.

Different content sections and classes can now be browsed from within Eclipse.

This window can then be used for reference purposes while working with EZ Templates and code.
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2.8 A Quick Tutorial
(The following is written by Nicolas Richeton, it sourced from comments provided here:
http://ez.no/community/contribs/documentation/installation_documentation_smile_ez_publish_eclipse_
plugin)
1. Open or create an ezpublish project in eclipse. Currently, the plugin doesn't provide any help
for this, so you can do it as usual.
2. select the ezpublish extension folder, right click and choose New->other->new operator
extension.
3. Choose a name for your extension and click on next.
4. Use the top "Add" button to create any number of operator.
5. For each operator, add parameters : select an operator and use the bottom "Add" button to
add parameters. Currently only String and Array parameters are supported.
6. Click on Finish. Extension directories and files are automatically created.
7. To add a new operator, select the extension and use New -> other -> new operator. The
previous wizard will open directly on the operators page, and you will be able to add / update
or delete operators.
Note: all files, except <yourextension>.php will be generated each time you click on finish.
Don't modify these files manually. <yourextension>.php is generated only the first time, you
have to update this file manually when you add/remove operators.
[End of Document]
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